failed to install INT2LM – in #12: CCLM Starter Package Support

in #12: CCLM Starter Package Support

The gfortran compiler in its standard configuration does not accept more than 132 signs per line. I have already fixed these long lines in the official int2lm code, but this version has not yet been unified with the clm version of int2lm.

You have two options, either make the lines shorter or tell the compiler to accept longer lines:

Option 1)

Modify the file src_gribtabs and add line breaks in the lines mentioned in your error message. For example to:

  IF (trcr_meta(i)%ilevtyp  110) THEN
    var_in(70+i) = ar_des_input(TRIM(trcr_meta(i)%shortname), TRIM(trcr_meta(i)%clevtyp) , trcr_meta(i)%grbtab, &
                                trcr_meta(i)%ilevtyp, trcr_meta(i)%grbnr,  0,   0,    1.0, 0.0, 3,              &
                                dum4,       tracer_in(:,:,1:kedim_in,i), dum2,'IB ',                            &
                                'QT'//trcr_meta(i)%flag_posdef,.FALSE., ke_in,   0)
  ELSE IF (trcr_meta(i)%ilevtyp  109) THEN
    var_in(70+i) = ar_des_input(TRIM(trcr_meta(i)%shortname), TRIM(trcr_meta(i)%clevtyp) , trcr_meta(i)%grbtab, &
                                trcr_meta(i)%ilevtyp, trcr_meta(i)%grbnr,  0,   0,    1.0, 0.0, 3,              &
                                dum4,       tracer_in(:,:,1:kedim_in+1,i), dum2,'IB ',                          &
                                'QT'//trcr_meta(i)%flag_posdef,.FALSE., ke1in, 0)
  ENDIF

Option 2)

Add the flag -ffree-line-length-none to COMFLG in your Fopts_INT

  @danielrieger in #b3714ff

The gfortran compiler in its standard configuration does not accept more than 132 signs per line. I have already fixed these long lines in the official int2lm code, but this version has not yet been unified with the clm version of int2lm.

You have two options, either make the lines shorter or tell the compiler to accept longer lines:

Option 1)

Modify the file src_gribtabs and add line breaks in the lines mentioned in your error message. For example to:

  IF (trcr_meta(i)%ilevtyp  110) THEN
    var_in(70+i) = ar_des_input(TRIM(trcr_meta(i)%shortname), TRIM(trcr_meta(i)%clevtyp) , trcr_meta(i)%grbtab, &
                                trcr_meta(i)%ilevtyp, trcr_meta(i)%grbnr,  0,   0,    1.0, 0.0, 3,              &
                                dum4,       tracer_in(:,:,1:kedim_in,i), dum2,'IB ',                            &
                                'QT'//trcr_meta(i)%flag_posdef,.FALSE., ke_in,   0)
  ELSE IF (trcr_meta(i)%ilevtyp  109) THEN
    var_in(70+i) = ar_des_input(TRIM(trcr_meta(i)%shortname), TRIM(trcr_meta(i)%clevtyp) , trcr_meta(i)%grbtab, &
                                trcr_meta(i)%ilevtyp, trcr_meta(i)%grbnr,  0,   0,    1.0, 0.0, 3,              &
                                dum4,       tracer_in(:,:,1:kedim_in+1,i), dum2,'IB ',                          &
                                'QT'//trcr_meta(i)%flag_posdef,.FALSE., ke1in, 0)
  ENDIF

Option 2)

Add the flag -ffree-line-length-none to COMFLG in your Fopts_INT

The gfortran compiler in its standard configuration does not accept more than 132 signs per line. I have already fixed these long lines in the official int2lm code, but this version has not yet been unified with the clm version of int2lm.

You have two options, either make the lines shorter or tell the compiler to accept longer lines:

Option 1)

Modify the file src_gribtabs and add line breaks in the lines mentioned in your error message. For example to:

  IF (trcr_meta(i)%ilevtyp  110) THEN
    var_in(70+i) = ar_des_input(TRIM(trcr_meta(i)%shortname), TRIM(trcr_meta(i)%clevtyp) , trcr_meta(i)%grbtab, &
                                trcr_meta(i)%ilevtyp, trcr_meta(i)%grbnr,  0,   0,    1.0, 0.0, 3,              &
                                dum4,       tracer_in(:,:,1:kedim_in,i), dum2,'IB ',                            &
                                'QT'//trcr_meta(i)%flag_posdef,.FALSE., ke_in,   0)
  ELSE IF (trcr_meta(i)%ilevtyp  109) THEN
    var_in(70+i) = ar_des_input(TRIM(trcr_meta(i)%shortname), TRIM(trcr_meta(i)%clevtyp) , trcr_meta(i)%grbtab, &
                                trcr_meta(i)%ilevtyp, trcr_meta(i)%grbnr,  0,   0,    1.0, 0.0, 3,              &
                                dum4,       tracer_in(:,:,1:kedim_in+1,i), dum2,'IB ',                          &
                                'QT'//trcr_meta(i)%flag_posdef,.FALSE., ke1in, 0)
  ENDIF

Option 2)

Add the flag -ffree-line-length-none to COMFLG in your Fopts_INT